Jump to content

560 hydraulics


seabee

Recommended Posts

I'd like to have more information...

You tested the pump and had it isolated from the system? If you did this and got a strong reading, then based on what you've written the pump cannot develop its rated pressure while it's output is allowed to go into the hydraulic system. Is this correct?

If so, then the first place to look is at the pressure relief. You could have a weakened or broken pressure relief spring. This condition will "dump" system pressure way too early not allowing the pump to develop a system pressure of 1500 PSI.

Link to comment
Share on other sites

I'd like to have more information...

You tested the pump and had it isolated from the system? If you did this and got a strong reading, then based on what you've written the pump cannot develop its rated pressure while it's output is allowed to go into the hydraulic system. Is this correct?

If so, then the first place to look is at the pressure relief. You could have a weakened or broken pressure relief spring. This condition will "dump" system pressure way too early not allowing the pump to develop a system pressure of 1500 PSI.

the pump was isolated, and i have had the regulator and safty block apart. i have shimed the safty with no results. looks to be impossible to adjust the regulator side. i have looked over ihc service section and there is no mention of being able to adjust the pressure. i guess i dont quite understand the system

joe

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...