Jump to content

Lol, For the Dodge Fans on here.


lorenzo
 Share

Recommended Posts

First car I actually owned was a 54 Chrysler Windsor.  Was a 2 door big coupe with the 265 (big I6)  and a 2 speed true automatic, not fluid drive . That was in 1965, cost $375 off of Chrysler dealers lot with around 60,000 miles on it.  I owned the car for about a year in Southern California, no issues with the car.  Looked a lot like a 53 Chevy, except BIG and almost a military green color. Only mod I made was to install seat belts for the front seat. Had the whinny starter motor and a 6V system. (never failed to start)  What I really remember was the Vacuum tube signal seeking AM radio.  I built my own vibrator and OZ2 rectifier replacement using genuine US Gov parts for the power supply. Switch on the floor to change stations. Looking back over many years it was about as trouble free as any vehicle I have owned. The AC was natures own, dash vents and vent windows.  AND Gasoline was .299 per gallon.

  • Like 4
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...