Jump to content

1466 cluth and steering issues


Farmall 1466
 Share

Recommended Posts

Got some issues with our 1466 that came up a couple of days ago. Clutch is really, really light (overboosting I feel) and engages abrupt, you dont have any control over that with the pedal. And at the same time, steering became dodgy. When driving, it is alright but when standing still, turning the wheel doesnt always make the tires rotate left or right. It takes a couple of rotations from the wheel, like it is building pressure or so. Before doing anything, I wanted to confirm my suspicions on mcv problems. Is the pump tired?

Thanks!

Link to comment
Share on other sites

2 hours ago, Farmall 1466 said:

Steering can be checked by removing the 5/8" plug below the relief valve, right?

Plug below relief valve will give you regulated pressure. Plug at back of mcv that takes a 5/8" wrench will give you steering or the Plug right above it or the Plug at the other end of that bore. Which is flow divider spool bore.

Link to comment
Share on other sites

  • 2 weeks later...
21 hours ago, Farmall 1466 said:

Steering was at ~1550 and regulated at ~150 so we'll change the pump definitely

Hy -capacity makes pumps and gasket sets.  While you've got it apart, if it was mine, I'd replace the springs in the MCV, too. They sell all of the springs in a kit, the part number is 830458.  It's about $50. 

Link to comment
Share on other sites

On 11/4/2022 at 9:10 PM, Mike56073 said:

Hy -capacity makes pumps and gasket sets.  While you've got it apart, if it was mine, I'd replace the springs in the MCV, too. They sell all of the springs in a kit, the part number is 830458.  It's about $50. 

Will definitely look into that. Thanks!

Link to comment
Share on other sites

  • 3 weeks later...

We had a relative of ours rebuilt the mcv and pump and the pressures are good now. We however still have some issues. Clutch is still funny and steering isn't completely solved either. Is there a possibility that the clutch booster is leaking internally or can this not cause the problems? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...