Jump to content

Case IH 7120 3 point hitch and 4WD problem


Recommended Posts

I have an Case International 7120 and the 3 point hitch has not worked on it in a few years. They are stuck down. You can move it by hand if you wanted to. Finally decided to sit down and figure out whats wrong with it. On the little LED screen on the flip open case it brings up the code H3 on startup and has a 3 the rest of the time. We wiggled the wiring harness a little under the tractor trying to follow it back and see where it went and now every once in awhile it flashes an F3 code.

All of a sudden the 4WD quit working too. I don't have a book for this machine so i can't lookup how to pull up the codes for it and all it says on the dash under the MPH is "service"

If someone could help me figure this out that would be great. Maybe i'd be able to plow with it again 😂😁

Link to comment
Share on other sites

The service indicator is just a timer set for whatever hour level you program in, hold two buttons it will shutoff. Probably a fuse or solenoid for the front wheel assist.

Link to comment
Share on other sites

We pulled all the fuses and checked them all and they were all good. I'll tear the side panel off the control panel tomorrow and see if i find any broken wires unless someone else has any ideas. If we can't figure it out we'll send it up to our buddy and have him fix it. Prefer to fix it ourselves though because it saves a few dollars😂

Link to comment
Share on other sites

Been a while since we had our magnum. Check tehwiring to the solenoid for the MFWD you may have pulled something loose trying to get the other issue fixed.  Believe solenoid is near the side full tank at rear?

Link to comment
Share on other sites

9 minutes ago, jass1660 said:

I would suggest getting a book for starters. Could be the large stud for battery power that goes thru cab.

@SDman @Maynard

We might have a book some place. Got so many books from old tractors over the years can't remember what exactly we have haha. I'll have to check it out though.

7 minutes ago, 5488Duke said:

Been a while since we had our magnum. Check tehwiring to the solenoid for the MFWD you may have pulled something loose trying to get the other issue fixed.  Believe solenoid is near the side full tank at rear?

Not sure about the solenoid for the 4WD I'd have to follow the wires, or try to. The 4WD hasn't worked in quite awhile either. I know where the one for the 3 point hitch is i think but i'd have to look for the other one

Link to comment
Share on other sites

My error code chart for 89 series Magnums shows as follows:

 

H3----Open circuit or short to ground of raise coil or raise coil circuit.

Failure Mode: HALT

Corrective Action: 

1.  Test wire harness for continuity.

2.  Test coil for resistance (6.4 to 6.8 ohms)

3.  Replace the control module.

 

The 3 is the last half of the code and will show in the window until it is fixed and the codes are cleared, when it is all working correctly, it should show a 0 in the window. My list doesn't show an F3 code, but I had saved this and it shows:

NOTE: If any of the following codes exist, there will be no hitch control. An "F" code flashes alternately with an error code.
The “F, 3” code flashing alternately, indicates a failure in the valve raise solenoid circuit.

Hope this helps.

 

Link to comment
Share on other sites

On 8/3/2021 at 8:00 PM, MagnumOwner said:

I have an Case International 7120 and the 3 point hitch has not worked on it in a few years. They are stuck down. You can move it by hand if you wanted to. Finally decided to sit down and figure out whats wrong with it. On the little LED screen on the flip open case it brings up the code H3 on startup and has a 3 the rest of the time. We wiggled the wiring harness a little under the tractor trying to follow it back and see where it went and now every once in awhile it flashes an F3 code.

All of a sudden the 4WD quit working too. I don't have a book for this machine so i can't lookup how to pull up the codes for it and all it says on the dash under the MPH is "service"

If someone could help me figure this out that would be great. Maybe i'd be able to plow with it again 😂😁

 

Here's the MFD circuit. Rather simple affair. Fair;ly common for the solenoid to fail, but,considering your hitch problem I would suspect the harness is rubbing somewhere and has caused a short.  

 

image.thumb.png.e294386859682056ab6dd0c60dca8db7.pngimage.thumb.png.c3387fe20a5e222d7475bcf7b689e8de.pngimage.png.e042f6af419d83aa18946b2440ce9781.png

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...