Jump to content

1450 Electrical problems


Red Flyer
 Share

Recommended Posts

I have a good starter, good relay and good switch. I have power to both sides of the amp meter but my switch seems to be dead. Is it possible the voltage regulator is my problem?

Thanks in advance.

 

APF

Link to comment
Share on other sites

Switches regularly go bad, also check for a bad safety switch (PTO often a culprit) as they are interconnected.

Try a jumper wire from the "start" post on the key switch and the solenoid trigger post......if its a safety interlock issue, this will bypass it temporarily. 

VR us not the issue.

Link to comment
Share on other sites

Try holding the key switch in the "start" position and wiggling the pto switch. Often times on Quietlines the pto switch will be just barely engaged and it will act as if you have a dead battery or a bad neutral start safety switch. Have had several here that have done this. Just a thought. If that works, replace the pto switch. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...