Jump to content

1066 PTO runs without stopping


1586 Jeff
 Share

Recommended Posts

I put clutches in my neighbor’s 1066.  Now the PTO runs constantly if there is nothing hooked to it.

If there is an implement hooked to the PTO it will stop the PTO shaft when the PTO is disengaged.

 I believe that the brake pressure is off from spec, but I cannot find how to adjust it in the I&T manual that I have for the 66 Series.

 I have the International Harvester manual for the 86 Series and it is incredibly detailed, but it only covers the new style PTO, not the older style PTO.

 Thank you!!!

Link to comment
Share on other sites

Pto brake is spring applied, clutch pressure overides spring pressure to releases brakes when clutch is engaged. Sounds like brake pistons shoes are shot or clutch pack has too many discs in it, clutch may have had play on bench, but once disc swell up after being soaked in oil could cause it to be to tight. Install a pressure gauge and make sure pressure drop to "0" when disengaged. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...