Jump to content

Recommended Posts

Hi I have tdc5 dott.

 I've rebuilt the motor, steering and put some seals in some of the rams.

I am pretty sure the hydraulic control are letting fluid by and causing the bucket drop etc.

I've taken them apart and given a bit of a hone but I think they might just be worn out.

Any one here can provide a solution as where to where I might find a new control box thing to suit a 4 in 1 bucket.

It seems a shame to have such a good old machine let down by the hydraulic controls.

 

 

Link to post
Share on other sites

I would put new seals ( O rings hopefully) on the piston inside the rams. If the seal on the rod was leaking the one inside is just as old,if not older. Not that you may not have some leakage in the valves as well. Generally valves have machined surfaces and it gets expensive as not many seals.Unless it valves stacked with then o rings between valves sometimes helps. The old part needs build up and turn down or put a new valve on. So reseal the ram and see how it goes.

Link to post
Share on other sites

I will agree with Ray , The rams are usually the problem ,  If I remember right your valve assembly should have "load check" valves that can be faulty

Do you have a parts book ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...