Jump to content

Recommended Posts

The one inch tube that comes up from the oil pump and makes a 90 degree bend to the oil cooler is leaking around the fitting that goes into the oil cooler. I ordered the correct o ring from CNH and replaced it. The oil leak stopped so I cleaned it all up and let it run for about half an hour. No leaks then the next day it started leaking again . Is there another o ring I can try or do I need some kind of sealant. Thanks in advance.

 

APF

Link to post
Share on other sites

Than

1 hour ago, beekeep15 said:

read it on here before 

Me too. Just could not find it. Thanks

APF

Link to post
Share on other sites

I just went through the same thing in my 806D.  There are actually 2 O-rings on each end of that fitting.. and the parts that I got from CIH didn't seem to be the correct rings even though they had the correct part number.  I ended up getting some out of an assortment set that worked.  Just make sure the elbow is clean when you reinstall it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...