Jump to content
Sign in to follow this  
JD Humm

2011 International Transtar 8600 electrical issues

Recommended Posts

The tech school I work for has a 2011 Transtar 8600 day cab single axle semi tractor we use for CDL instruction.  It was raining the other day when I took it out with a student.  Wipers, ac, horns were working fine when we left the yard.  A few miles into our training session the wipers quit working along with the AC and the blower motor.  Notice later the horns did not work.  Took it back to the school yard and checked fuses, all were good.  The school took it to a local medium truck shop which has since started throwing parts at it.  The got the blower motor to work but there is still no power to the AC compressor.  They even recharged the AC with no luck.  They put on a new wiper switch.  New wiper motor.  No luck.  Highway horn still does not work.  Anyone have any ideas what else to look at?  FWIW the radio does work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...