Jump to content

966 steering motor replacement


Recommended Posts

replaced seal under steering wheel and I thought it took care of leaking issue,

   used it through planting and first cut of hay and steers harder and leaks out the bottom now. leaks bad at start up .

need to probably replace now.   Where is best reasonably priced place to get one ? any ideas? 

not sure I want to go the new seal rebuild myself route ,I  envision nightmares with that , 

Link to post
Share on other sites

Does it leak out of the steering pump or the lines?  My 966 this spring had a leak that I originally thought was the steering pump.  When I pulled the center panel off the lower dash I found a loose pipe connection under the pump. 

Link to post
Share on other sites
14 hours ago, plowboy64 said:

replaced seal under steering wheel and I thought it took care of leaking issue,

   used it through planting and first cut of hay and steers harder and leaks out the bottom now. leaks bad at start up .

need to probably replace now.   Where is best reasonably priced place to get one ? any ideas? 

not sure I want to go the new seal rebuild myself route ,I  envision nightmares with that , 

Tey arent that hard to do. As far as the hard dteering issue, when you put your top seal in did you just take it out or did you pull the housing off the hand pump that the seal is in? Reason I ask is if you pull that hosuing and dont get it lined up perfect going back it will steer hard. I always take a hose clamp and go around the body and housing and tighten it down before I tighten the bolts.

Link to post
Share on other sites

If it leaks bad at startup and gets better as it warms up it's more than likely the rubber sleeve at the bottom of the pump. The heat causes expansion and it seels better. If it leaks the same no matter how long you run it's more than likely a o-ring on one of the fittings.

Link to post
Share on other sites

This is why I say to remove the handpump and rebuild them, not just put a seal in at the top.  I believe I suggested removal when you asked earlier about replacing the upper seal.

Take it out and rebuild it. New handpumps are expensive. 

Link to post
Share on other sites

when I replaced top seal I just removed the seal and replaced as per instructions in the kit. did not remove pump from tractor.

as far as the hard steering could it be that once top seal quit leaking it made bottom leak? causing hard steer issue ? hard steer issue started after top seal replacement 

still seems to only leak at start up .

took all sheet metal off yesterday and degreased so I can see better where it leaks from. will try to get a better look at things tomorrow .

my worry is motor is going bad ??   

Link to post
Share on other sites
1 hour ago, plowboy64 said:

my worry is motor is going bad

Highly unlikely.  Those handpumps very seldom fail. 

When you stop up a leak at one point, the next weakest link gives out.  In this case, likely the lower seal.  You may have gotten dirt in the end when changing the seal.  It may not be seated correctly. Also, with no leak there will be an increase in pressure, which could make it steer a bit harder, but at the same time, you may be losing pressure supply to the pump at the new leak.... all possible likely causes of what you describe. 

Again... remove and disassemble it.  I would also suggest replacing the thrust and shaft needle bearings while it is apart.  If you aren't confident in this repair, remove the pump and take it to a hydraulic shop or local CIH dealer for repairs. 

In my opinion, replacing with a new pump would be like replacing an engine because the rear main leaks. Just fix what you have. 

  • Like 1
Link to post
Share on other sites

Hard steering can also be from a weak MCV pump or blown orings in the MCV valve. The leak may just be another bonus you are blessed with.

  • Like 1
Link to post
Share on other sites
On 6/21/2020 at 4:32 PM, plowboy64 said:

when I replaced top seal I just removed the seal and replaced as per instructions in the kit. did not remove pump from tractor.

as far as the hard steering could it be that once top seal quit leaking it made bottom leak? causing hard steer issue ? hard steer issue started after top seal replacement 

still seems to only leak at start up .

took all sheet metal off yesterday and degreased so I can see better where it leaks from. will try to get a better look at things tomorrow .

my worry is motor is going bad ??   

Those steering motors usually don’t go bad. Nothing as far as replacing top seal is going to make it steer hard or loose pressure with bottom seal leaking. Bottom seal just gets hard starts to leak. Taking pump out isn’t a bad deal but seal on other end is more complicated to replace. The hard steering is low pressure from mcv valve or Benny spindle or bad thrust bearings on spindle.

Link to post
Share on other sites

got the steering hand pump out last evening ,with a few dr. visits and working I probably wont get back to it for a day or two ,will be nice to get the greasy mess cleaned  up and stopped

will post a follow up , thanks for the advice guys!! 

Link to post
Share on other sites
  • 2 weeks later...

finally had the time to get steering pump seal replaced , its a bear to get everything lined up to get lines back on .. power washed and degreased seems to work better . so we will see..

once again thanks guys for your helpful advice.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...