Jump to content
Adrian 2094

Case mfwd gear problem

Recommended Posts

Hi all I need a bit of help I completely stripped my 2094 and rebuilt the gearbox on the first test drive everything worked 100% but after a bit the hydrolics filter light came on so I put new ones in and cleaned out the transmission filter screen reassembled it all went to move her and she was surging in gear then the filter light came back on again I have put new oil in the back end at the right grade and right level now if you put her in gear she is trying to move but won't move any ideasĀ 

Share this post


Link to post
Share on other sites

Perhaps a pump problem? Was there metal in your filter or old fluid?

Share this post


Link to post
Share on other sites

Check your charge pump pressure . There is a sender in the big hyd line that goes to the piston pump , that is the sender that operates your filter light , take out sender and screw a gauge into that port . 100 psi gauge is sufficient . If my memory serves me correct it should read around 20 psi with warm oil at rated rpm .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...