Jump to content
Sign in to follow this  
Repete

584 Hydraulic lacking

Recommended Posts

My 584 lacks power when lifting the loader or three point. Power steering works well and fluid and filter are clean. Any thoughts as to what might be going on?

Share this post


Link to post
Share on other sites

Likely a bad relief valve and/or the Orings that the valve seals against. Hy-Capacity has 2800 psi relief valves at a reasonable price.

Share this post


Link to post
Share on other sites

You got a part # that’s all that’s wrong with my 674. Just short on balls. Can put up with slow. 

John

Share this post


Link to post
Share on other sites

Thanks Guys. I had the relief as well as the Priority valve out and they both looked good. The "O" rings on the relief I could not see and if I pulled them out I had may as well put new in. Maybe I will get out my little "rectal scope" and see what I can see.

Share this post


Link to post
Share on other sites

Unless you completely disassembled the relief valve you wouldn't know if it was bad... And even still, it's hard to tell. Do you have another IH tractor around that you could borrow one out of for testing?

Share this post


Link to post
Share on other sites
3 hours ago, Farmall Doctor said:

Unless you completely disassembled the relief valve you wouldn't know if it was bad... And even still, it's hard to tell. Do you have another IH tractor around that you could borrow one out of for testing?

Would this be beyond removing the internal snap ring, screen and spring? Maybe I did not look deep enough into it.

Share this post


Link to post
Share on other sites
1 hour ago, Farmall Doctor said:

Other than the pintle, I guess that's it.

All looked to be in order but of course I have no idea of the spring pressure etc. Since the problem did not seem to progress slowly, I would not suspect the spring pressure unless the spring was broken which it was not. Still cannot determine if the "O" ring(s) have failed but will look inside.

Thanks for taking the time to reply and offer help. 

Gregg

Share this post


Link to post
Share on other sites

Isn't there an oil pickup strainer inside the transmission somewhere.

Iirc it is visible through one of the  front two drain plugs?

I have a vague memory of someone blowing one off with an airline.

Could a blocked strainer cause these sort of symptoms?

Share this post


Link to post
Share on other sites

There is no strainer on that pickup tube that I'm aware of. There is one on the lube pump.

Share this post


Link to post
Share on other sites
4 minutes ago, snoshoe said:

There is no strainer on that pickup tube that I'm aware of. There is one on the lube pump.

I am only throwing the hypothetical balls in thw air. There is something about this strainer in my head and someone cleaning it.

But I honestly cant remember the details.

I'm always willing to ask and listen, and maybe learn?

Share this post


Link to post
Share on other sites
3 minutes ago, Pid 1831 said:

I am only throwing the hypothetical balls in thw air. There is something about this strainer in my head and someone cleaning it.

But I honestly cant remember the details.

I'm always willing to ask and listen, and maybe learn?

If lube strainer plugs or pump fails it doesn't return enough oil to rear frame. The main pump then starves for oil. That affects steering and control circuits as well. His complaint is hitch and auxillary

Share this post


Link to post
Share on other sites
11 hours ago, snoshoe said:

If lube strainer plugs or pump fails it doesn't return enough oil to rear frame. The main pump then starves for oil. That affects steering and control circuits as well. His complaint is hitch and auxillary

Fair enough.

I hadnt thought it through like that. Quite logical now you mention it.

Thank you it is appreciated 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...