Jump to content

Recommended Posts

I bought a 1586 recently for a baling tractor, and the fan had a noise in it so I just never ran it. I ordered a new fan and replaced it. With the tractor not running the fan kicked on just fine, but when I started the tractor it will not turn back on. So I killed the engine and still nothing. Any insight? 

Link to post
Share on other sites

Does the radio and windshield wiper still work? If not it's the cab solenoid. If that works for you check the fan switch,fuse under the dash, key switch it's self can cause it usually you can wiggle the key switch and it will go back to working let us know what you find out

Link to post
Share on other sites
5 hours ago, Joshrod14 said:

I bought a 1586 recently for a baling tractor, and the fan had a noise in it so I just never ran it. I ordered a new fan and replaced it. With the tractor not running the fan kicked on just fine, but when I started the tractor it will not turn back on. So I killed the engine and still nothing. Any insight? 

Gotta be somewhere 

AF306754-3011-41CA-B428-466DE3DF1ADE.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...