Jump to content
Sign in to follow this  
Missouri Mule

4l80e guys

Recommended Posts

Ever have a bad day? The other day my truck blew an oil cooler hose on the highway. I caught it quick because it was spraying on the manifold 😳. Lots of smoke but I got it pulled over and repaired the hose. Limped it 1/2 mile and put 2 qts of oil in. Dipstick showed full so I thought. Here’s where it gets bad. I drove it a few days feeding cows probably 5 miles each day. Today on the way home it wouldn’t shift into od or lockup not sure which. Was only 1/2 mile from home when I thought damn i wish I had double checked that fluid now😢 (too much of a hurry)well it was 3 qts low!  Omg 🤬  I took it for a spin and it shifted perfect. Truth told I probably drove it 30 miles total that low short distances.  Feel pretty stupid. Did I mention this tranny is brand new? $1900....feeling real stupid now. So tranny guys did I screw it up or you think it went into a limp mode on temp or something? 

  • Sad 1

Share this post


Link to post
Share on other sites

Did your check engine light come on?  If it stayed off I wouldn’t worry about it as long as the fluid doesn’t smell burned.    The weak part in those transmissions is actually the torque converter clutch inside the converter.  3 quarts low sounds about right for not shifting all the way up.

           I was a tranny guy at the local GM dealership for 19 years.  If you did any damage, it should’ve kicked the light on by now......

Share this post


Link to post
Share on other sites
On 4/17/2019 at 9:51 PM, Mike56073 said:

Did your check engine light come on?  If it stayed off I wouldn’t worry about it as long as the fluid doesn’t smell burned.    The weak part in those transmissions is actually the torque converter clutch inside the converter.  3 quarts low sounds about right for not shifting all the way up.

           I was a tranny guy at the local GM dealership for 19 years.  If you did any damage, it should’ve kicked the light on by now......

No light no burnt smell. Hopefully I’m good

Share this post


Link to post
Share on other sites

Never ran my 4l80e low but I've ran it hard. Pulled about 18k in my 98 K2500 with a 454 quite a few times and it's never given me any issues

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...