Jump to content

Recommended Posts

Bought this old TD9 a couple of weeks ago.

IMG_20160327_191136.jpg

image free hosting

IMG_20160327_190400.jpg

image hosting site no sign up

It was not running and had no gas cap on the tank so I only paid about what it was worth in scrap.

I took it home and cleaned the tank, hoses and changed the fuel filters. I also made a new gas cap.

When the time came to start it up I put a fresh battery in it and tried to crank it but it felt very tired.

The starter came off and got new bearings.

What a differense!

IMG_20160327_080657.jpg

pc screenshot

After the air was bled out of the system the motor fired up in a cloud of black smoke. But it did not respond very well to the throttle and it only ran for a few minutes and then it cut out. There were also a knocking noise like it was not running on all six cylinders.

I tried cranking it right away after it cut out but it did not want to start again.

I checked the filters for air but there were only fuel.

After about 10minutes I cranked it again and it started right up again only to cut out again after a minute or two.

I have tried many times now but its the same every time.

I also put on an electric fuel pump too feed the system but there are no improvements.

I think the problem is in the injection pump. Its an RD injection pump i belive. Not so common nowdays?

IMG_20160331_174117.jpg

picture upload

Are there any easy fix to this problem or do the pump need rebuilding or replacing?

//Johan from Sweden :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...