Jump to content

Search the Community

Showing results for tags 'v800'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Boards
    • Technical IH Talk
    • General Chat
    • Projects, Builds, & Restorations
    • Support
    • Announcements
    • IH Construction Equipment
    • IH Trucks
    • IH Engines
    • Cub Cadets
    • IH Toys, Memorabilia & Collectibles
  • Archives
    • Archived Posts

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello everyone, first post. I just bought my first dozer, a 1980 Dresser TD-20E. (thanks to the fine folks on this forum for posting serial number lists, that's how I know the year) The machine was only used to clear about 5 acres for housing lots in the last year and a half. Before that it was a farm dozer. I don't know anything about it prior, nor do I know how long it was a farm dozer. The machine is in great shape as far as I can tell. The man I bought it from changed trans, hydraulic, and engine oil. My plan now is to: Replace/clean all filters Flush and replace final drives Check frame pivot oil/grease level (any help would be appreciated, there is no drain on the side like the book shows, and no zero on top so I'm guessing I just fill it all the way up with gear oil?) I can post pics of that later. Change engine oil I have already replaced the seat, the cushions were history. I had a nice hardly used seat from my zero turn so it is now part Kubota (sorry lol) I also removed the blade and built up the trunions, they were wore very badly, will post pics. I have removed the right side engine shield and straightened and welded it so it operates properly... will also fix the left side. It is missing a small part of the cutting edge, going to call a few places and see if they can help me out It operates great with the exception it seems a little weak on power, but I need to run a little more and get used to it and then I can post some videos and see if anyone has advice on that topic. Who knows how many hours are truly on it, the meter shows 500... the motor may be getting weak or the turbo isn't building boost, not sure. PICTURES HERE: https://www.amazon.com/photos/shared/l2S418pTQ-urMezPBNfndw.qZt_-bDvqFZs2uaZ6DOr-T CLICK HERE FOR PICTURES
×
×
  • Create New...