Search the Community

Showing results for tags 'oil pressure'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Boards
    • General IH
    • Coffee Shop
    • Projects, Builds, & Restorations
    • Support
    • Announcements
    • IH Construction Equipment
    • IH Trucks
    • IH Engines
    • Cub Cadets
    • IH Toys, Memorabilia & Collectibles
  • Archives
    • Archived Posts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Farmall504#20

    Low oil pressure ?

    Ive got at IH 140 tractor and I noticed during a parade that after about 30 mins the oil pressure dropped to almost zero . I had recently changed the oil and put a new filter ( it has the factory spin on filter ) on it and now this happens after 30 mins of use . The same thing happend to a friend of mine on his 140 when he used the same filter ( Napa Gold ) when he changed his oil . Only reason I used that filter was it was white and I was able to use the IH ( Oil Lube Filter ) decal I had made to look original . Should I change the filter to the CIH filter and see if that works ? . I bought another gauge and will try to see if it is the cause as well . the tractor does not Knock or burn oil so i know its not that . any help thanks . This is the other decal the one I used says "Oil Lube Filter" not just oil filter