Jump to content

Search the Community

Showing results for tags 'help'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Boards
    • Technical IH Talk
    • General Chat
    • Projects, Builds, & Restorations
    • Support
    • Announcements
    • IH Construction Equipment
    • IH Trucks
    • IH Engines
    • Cub Cadets
    • IH Toys, Memorabilia & Collectibles
  • Archives
    • Archived Posts

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. My 1066's (5600 hrs) rear hydraulics went out, no remote power or 3 pt power. I have the hitch pump out of it now. The seals were intact, just a bit smashed. I have new seals to change it out, but if that doesnt work. I will probably get a new pump, though all of the pumps i have found with the part numbers that i have, have two ports and mine only has one. So its throwing me off a bit. So I guess i am asking, if i change the o-rings and put it back in and it still doesnt work, is it the pump? or do i look at another part? Thanks in advance.
  2. Looking at buying a Case IH Maxum 5120. Has transmission with 4 ranges and 4 speeds. Both shifters are in an H pattern. Speed selector seems to be stuck in third gear. Range selector works as it should. Tractor moves forward and back and drives fine. Is this a serious problem or is it a simple linkage issue
×
×
  • Create New...