Jump to content

redpower123

Members
  • Posts

    182
  • Joined

  • Last visited

Everything posted by redpower123

  1. Do they sell directly or do you have to go through a dealer
  2. I have had both at the same time and the 1466 can put it on a 1086 but it should its a bigger tractor
  3. I was checking my fan belts and one is a little bit looser than the other,I just got them last year and they were a matching set zip tied together, and I was wondering how tight is too tight. Thanks
  4. I used to have a 1086 that had both 540 and 1000 that’s well over 85hp
  5. It will help if you don’t disassemble upside down 😂
  6. Was thinking about putting one on my 14 my muffler is on its last leg.Where is a good place to find one and what size. thanks
  7. Thanks for the help and all the pictures it helps me to see what I’m getting myself into
  8. Same here no problem with caseih mechanical diode in my 1466 put it in around 10 years ago
  9. Thanks for all the responses I appreciate your help
  10. I have a bad leak on the furrow side axle so I thought I would try to change both seals and bearings while I’m in there,does anyone have any pictures of what this animal look like when you tear into it and any advice appreciated thanks.
  11. That sounds like some of my luck most of the time they never heard of or seen some of the problems I have lol 😆
  12. I’ve used shaeffers synthetic blend in my 1466 and 1460 for years I even run it in a 830 jd two cylinder that’s a 59 model
  13. Had the same problem with my 5488 wire on the left hand side battery was corroded into fixed that and it worked like a charm
  14. Thanks Mike.I pulled those fuses for the sentry and cleaned them up a little,and put them in and out a few times,now the sentry light comes on like it should,only thing left now is the alternator. I will check that out tomorrow. I’ll be talking to you soon you got some nice stuff that I need for my tractor Happy Thanksgiving
  15. Found out part of the problem wire on left hand side was either burnt or corroded into. I couldn’t see it wasn’t attached because it was kind of under the battery terminal.So now the digital tach works and the tractor moves now.The diagnostic test when you turn the key on works except the sentry light and the alternator gauge isn’t working other than those two things the tractor seems fine but I don’t like the sentry light not coming on thanks for everyone’s help
  16. Wouldn’t it be hard to start maybe it wouldn’t I don’t know alot about electrical
  17. Oil pressure is working too as you can see radio lights air conditioning all work fine
  18. Update got two new batteries put them in tractor started up like it should alternator gauge isn’t registering digital tach isn’t working still won’t move fuel gauge works something is strange
  19. That’s called about a half day getting it on
  20. Would the cab selionoid be part of the problem yes the lights radio air all works fine
×
×
  • Create New...