Jump to content

RGF2021

Members
  • Posts

    5
  • Joined

  • Last visited

RGF2021's Achievements

Newbie

Newbie (1/3)

4

Reputation

  1. I will reply to my own question in case someone else has same issue. Pulled #1&2 injectors and had them tested and set to proper pop off pressure along with #3&4 to 3000psi. Before I put them in I ran a compression test. Couldn't get #3&4 to register anything. Then it hit me, adjacent cylinders with low compression.....blown gasket between the two cylinders. Pulled the head and that was the problem. Bought new top end gasket set for $56, put it back together and runs great!!
  2. I will reply to my own question in case someone else has same issue. Pulled #1&2 injectors and had them tested and set to proper pop off pressure along with #3&4 to 3000psi. Before I put them in I ran a compression test. Couldn't get #3&4 to register anything. Then it hit me, adjacent cylinders with low compression.....blown gasket between the two cylinders. Pulled the head and that was the problem. Bought new top end gasket set for $56, put it back together and runs great!!
  3. Hot Shot's Secret is the brand. (Diesel Extreme) is a fuel additive that adds Cetane, lubricity, fuel stabilizer and cleaner. Www.hotshotsecret com/diesel-extreme/
  4. Last weekend I bought a 3500A Backhoe with D239 that sounded like it was running on 2 to 3 cylinders. Owner stated it ran fine last fall but this spring started running rough. He said IP was replaced or rebuilt a couple years ago and also #3 & #4 injectors. I broke injector lines loose one at a time. # 1 and especially #2 would kill engine if not tightened back up quickly. #3 and #4 no real change in tone of engine. 1&2 would blow fuel when line is loosened, 3&4 would slobber fuel. I took out 3&4 injectors and had them cleaned and tested. She said #3 was ok, #4 was popping at 2200, set it I think she said at 2600. I put them back in and now it runs better but still black smoke and not running on all 4cylinders. I have the fuel shut off lever all the way to top on the control and is hitting the stop on the pump as well. With it running at maybe 2/3 throttle it will all of a sudden start boiling out white smoke and knocking. I shut it down and restart and i am back to black smoke, real heavy when reving engine up. With air cleaner off or on no difference. I added Hot Shots secret diesel extreme 1st thing thinking maybe things were gummed up. I have now drained the fuel tank and cleaned it out. Added fresh fuel and Hot Shot Secret again and new fuel filter. I forgot to add I pulled valve cover and placed engine on #1 and 14* BTDC and pulled pump gear cover and it was on 4 along with timing cover on IP with its mark aligned as well. It has the VA CR pump. It has electric fuel shut off but im not sure if it has automatic fuel enrichment or not. I also adjusted the valves to spec. I pulled the delivery valve on #3 of the IP and thought maybe it had water or debris but nothing. I cant get 1 & 2 injectors to come out but thought they seem to be ok so i have left them alone. With laser temp gun 1,2 and now 3 pretty much run same temp at exhaust manifold but #4 is down 50 to 75 degrees but was 100 before injector clean and and tested. It has a electric lift pump added, i thought maybe that made it over fuel, didnt made a noticeable difference when not plumbed in before i had injectors tested, now dont see a difference with it plumbed in. Im at wits end and more than ready for some assistance. I apologize for the long post but wanted to throw it all out there to pick every ones brain. Thank You in advance , I appreciate the help.
  5. Last weekend I bought a 3500A Backhoe with D239 that sounded like it was running on 2 to 3 cylinders. Owner stated it ran fine last fall but this spring started running rough. He said IP was replaced or rebuilt a couple years ago and also #3 & #4 injectors. I broke injector lines loose one at a time. # 1 and especially #2 would kill engine if not tightened back up quickly. #3 and #4 no real change in tone of engine. 1&2 would blow fuel when line is loosened, 3&4 would slobber fuel. I took out 3&4 injectors and had them cleaned and tested. She said #3 was ok, #4 was popping at 2200, set it I think she said at 2600. I put them back in and now it runs better but still black smoke and not running on all 4cylinders. I have the fuel shut off lever all the way to top on the control and is hitting the stop on the pump as well. With it running at maybe 2/3 throttle it will all of a sudden start boiling out white smoke and knocking. I shut it down and restart and i am back to black smoke, real heavy when reving engine up. With air cleaner off or on no difference. I added Hot Shots secret diesel extreme 1st thing thinking maybe things were gummed up. I have now drained the fuel tank and cleaned it out. Added fresh fuel and Hot Shot Secret again and new fuel filter. I forgot to add I pulled valve cover and placed engine on #1 and 14* BTDC and pulled pump gear cover and it was on 4 along with timing cover on IP with its mark aligned as well. It has the VA CR pump. It has electric fuel shut off but im not sure if it has automatic fuel enrichment or not. I also adjusted the valves to spec. I pulled the delivery valve on #3 of the IP and thought maybe it had water or debris but nothing. I cant get 1 & 2 injectors to come out but thought they seem to be ok so i have left them alone. With laser temp gun 1,2 and now 3 pretty much run same temp at exhaust manifold but #4 is down 50 to 75 degrees but was 100 before injector clean and and tested. It has a electric lift pump added, i thought maybe that made it over fuel, didnt made a noticeable difference when not plumbed in before i had injectors tested, now dont see a difference with it plumbed in. Im at wits end and more than ready for some assistance. I apologize for the long post but wanted to throw it all out there to pick every ones brain. Thank You in advance , I appreciate the help.
×
×
  • Create New...