Jump to content

PeteG

Members
  • Posts

    5
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

PeteG's Achievements

Newbie

Newbie (1/3)

0

Reputation

  1. I did try eBay and have been calling a few used parts places as well. NOS would be great if I could find. Part number is 1962571C1 from what I’ve found. Has anyone had luck getting into a tach? I just need the needle replaced, the actual hourmeter and tach still function
  2. Hi everyone, We have a Case IH265 that the tach needle broke on. The tach still works, it’s just a little hard to see. I contacted Star Speedometer, but unfortunately he said it’s too new of a tach and built in Japan so he wouldn’t be able to rebuild it. I also tried D&M in South Carolina, but they said they couldn’t do tractor tachs for some reason. Of course OEM is NLA but I was hoping someone might know of another shop. Any suggestions welcome, thanks!
  3. Hi everyone, I was able to get my 5250 Powershift working correctly with all your help so a big thank you to everyone. I have one other question, the speed display on the dash reads 0.0. I tested the wires and had 12v, so I assumed it was the sensor. Just replaced the sensor and still nothing. Anything else to check? Thank you again.
  4. Thanks a lot! I ordered the parts. One other question, the ground speed isn’t showing up on the dash. Is there a sensor that reads this? I’ve searched and found posts about radar units, and I’m not sure if that’s the correct part to be looking at?
  5. Hi everyone, I’ve been having an intermittent problem with our 5250 for a while now. When in any power shift gear except 3, the check trans light flashes 6 times in either forward or reverse. The tractor moves about an inch or so and then stops, like it’s in neutral. The dealer was out a while back, however the tractor decided to work perfectly for the tech. He mentioned the power shift pressure switches as a common failure, I just wanted to make sure before ordering the parts. The 6 flashes is showing none or multiple clutch pressures, and I just want to make sure it’s not the solenoids instead. All pressures were fine when he checked them, this is what’s leaving me to believe it’s a power shift problem. Also, when moving the power shift lever, there is a noticeable thud in each gear, which makes me believe the solenoids are working correctly, and it’s the switches but I could be wrong. Thank you for your help!
×
×
  • Create New...