Sign in to follow this  
Pete1468

Programmer for c15

Recommended Posts

6 hours ago, 806 man said:

Look behind the air compressor for harness rubbing , My Cat 3406E had 5 wires worn through and shorting out. Kept throwing codes spent mucho deniro going to cat dealer which kept changing out sensors cause the computer says. then im the one to find issue and  fix it.:angry:

Will do, I cut the harness after the compressor where it turns up to go across top front.  All the wires were pretty much welded together even where I stopped replacing, didn't see any broken or frayed past that back to ecm but sure didn't split harness to check.  That is My next job is split the rest and check, just hate to spend close to a grand for the harness.

Share this post


Link to post
Share on other sites

Pete,. Have you pulled the hoses off the inter cooler and looked in there?    I run a C13 at work.   Air to air cooler dumped antifreeze in inter cooler  made it a turd.   Just something easy to check.   

Nate

Share this post


Link to post
Share on other sites
58 minutes ago, nate said:

Pete,. Have you pulled the hoses off the inter cooler and looked in there?    I run a C13 at work.   Air to air cooler dumped antifreeze in inter cooler  made it a turd.   Just something easy to check.   

Nate

I haven't but I'm not loosing antifreeze that I've seen.

Share this post


Link to post
Share on other sites

Mine was not a notable loss either.   Gummed it all up was hard to move air.  

Share this post


Link to post
Share on other sites

Cattech,  have you done any before & after dyno testing with any of the ceramic coated exhaust manifolds?  FWIW, my truck came with a Full Throttle manifold (6NZ).

Share this post


Link to post
Share on other sites
18 hours ago, red211 said:

Will do, I cut the harness after the compressor where it turns up to go across top front.  All the wires were pretty much welded together even where I stopped replacing, didn't see any broken or frayed past that back to ecm but sure didn't split harness to check.  That is My next job is split the rest and check, just hate to spend close to a grand for the harness.

New harness was worth the money , I haven't had any issues with the engine since then that was 6-7 years ago.  seems like my harness was $400 years ago for 3406 E

Share this post


Link to post
Share on other sites
13 hours ago, ihrondiesel said:

Cattech,  have you done any before & after dyno testing with any of the ceramic coated exhaust manifolds?  FWIW, my truck came with a Full Throttle manifold (6NZ).

I hadn't heard how they did on a 6NZ, however that is one of the modifications our warranty department doesn't seem to raise a fuss about. We have installed several on BXS-NXS twin turbo ACERTs, powerwise wasn't a huge gain, but mileage was considerably better.

Share this post


Link to post
Share on other sites

We're hoping we do found our problem.  Three of the injectors weren't programmed, they were running on default mode.  Didn't run it on a dyno.  Waiting to take it on a test drive home here shortly.

Share this post


Link to post
Share on other sites

That will be great if it fixes it, love the easy repairs!!

Share this post


Link to post
Share on other sites

Wow, that will be an easy fix if that solves your problem.

Hope that does the trick. Very frustrating to have a truck that is a dog when you know it shouldn't be.

Share this post


Link to post
Share on other sites
8 hours ago, hillskinefarms said:

 

 Very frustrating to have a truck that is a dog when you know it shouldn't be.

X1000

Share this post


Link to post
Share on other sites

I'll have dad haul some corn Monday, 5 mile haul but hopefully he can notice a difference.

Share this post


Link to post
Share on other sites
5 minutes ago, Thesd5488 said:

So how’s she running with six injectors

X2!!!

Share this post


Link to post
Share on other sites

Hard to tell without me driving it but dad claimed he didn't have to shift on a small hill he normally had to.  Tomorrow he'll haul corn a little farther away over some good sized hills.

Share this post


Link to post
Share on other sites

Update?

Share this post


Link to post
Share on other sites
13 minutes ago, Cattech said:

Update?

X2

Share this post


Link to post
Share on other sites

I still haven't driven it with a load but he was pulling some good sized hills  with a little over 80,000 on and once he was rolling didn't have to shift.  Knowing the hills he was on I'm going to say it's running like it should.  I've got warranty left until November so I'm not going to do any tuning until that's over for sure.

Share this post


Link to post
Share on other sites

That sounds promising, I still need to do harness repair on Mine.  In 8th on interstate and light throttle it pulls like a boss, derates some after half throttle but until repair is done nothing else can be done.  

Share this post


Link to post
Share on other sites

Cats have some of the best torque out there if there running right nothing will put lug them

Share this post


Link to post
Share on other sites

Interesting........I would love to run some of these Detroits, because I have never seen one hold a candle to a yellow engine on a grade.

 Old school here, give a good mechanical..........you guys can flash, crash, and bash your ecm's.

Share this post


Link to post
Share on other sites
7 hours ago, TP from Central PA said:

Interesting........I would love to run some of these Detroits, because I have never seen one hold a candle to a yellow engine on a grade.

 Old school here, give a good mechanical..........you guys can flash, crash, and bash your ecm's.

We have a 425 b model pump is maxed out different turbo runs nice but don’t think it would run with my 550 e model before I tuned it the e’s have unreal bottom end I do like the old b model kinda fun to

Share this post


Link to post
Share on other sites
10 hours ago, DONS 504 said:

question is that 80000 gross

The grain trailer goes from 80,000 gross to 86,500 on one trip.  With the d7 on there it's 98,000 gross.  

Share this post


Link to post
Share on other sites

I'm hauling grain with it today, night and day difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this