red5770

MTD 782 Hydro chatter/vibration

Recommended Posts

My son has a MTD 782 that has a chatter/vibration in the hydro just after it starts to move and just before it stops. Sounds the worst at wide open throttle, forward or reverse. Not bad at 2/3's throttle if you change directions slowly. Mowing speed it sounds and runs good.

Transmission is full of clean oil, haven't changed the filter yet, bought it early this spring.

Any advice welcome. Thanks, Steve

Share this post


Link to post
Share on other sites

Is the chattering effected by temperature?  Worse when cold or first started,  decreases in intensity as the hydro oil gets Warm?

The MTD 782 used the same parts as an IH 782, same Sundstrand 15U hydrostatic transmission.  I would get a new oil filter on it ASAP,  sounds like it's cavitating the charge pump or piston motor.  The Hydros whine, some quite a lot, but normally run smooth.

Share this post


Link to post
Share on other sites

and make sure you use hy-tran oil in the trans.

Share this post


Link to post
Share on other sites

Check the drive shaft 

If the bushing or rag joints are bad it will cause vibration and chatter 

Share this post


Link to post
Share on other sites

Thanks guys, I'll get a new filter and check the driveshaft. 

Steve

Share this post


Link to post
Share on other sites

had a 1450 that had a chatter a few years back and it was a couple bad pistons in the hydro pump. it would chatter real bad when going up hill. throttle back on flat ground and it wasn't to bad

Share this post


Link to post
Share on other sites

Everything seems back to normal with a new filter. 

Thanks guys,

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now