Sign in to follow this  
Cp 856

706 no steering

Recommended Posts

Cp 856    0

I just got a 706 diesel it has no steering. We drove it on the trailer but when we got it unloaded it quit moving if you play with it it will start moving again but still no steering. The breaks work good all the time. So my question is it the mvc pump or something else. It drove good onto the trailer just no steering. I got it from a estate auction they didn't know much about it but it had been setting a while. I am hoping it's just the pump but don't know. Thank for the help

Share this post


Link to post
Share on other sites
3588pfcred    0

The pump may be bad or lost it's prime from setting at rear of MCV below Tran lube switch there is a small plug that is direct passage to pump, take plug out, start tractor and in 2 seconds you should have oil coming out be prepared to shut it off, install plug and start to up again to see if it works.  Steve

Share this post


Link to post
Share on other sites
Cp 856    0

Just got it power washed off and pulled into the shop it slobbers pretty bad out the exhaust and runs fairly smooth but has puff of smoke every time it fires on one cylinder but I think it's an injector. It still has no steering but has fluid out the bottom port on mvc. It will move on the low side of the t/a but if you shift it it either stops moving in high and low t/a or just moves the same speed as low the breaks work but not that good but feel like they have a good Pedal not really sure where to go from here.

Share this post


Link to post
Share on other sites
ih crazy    0

X2 on what Steve said, also check the oil level and since tractor is new to u change the hyd filter before u tear into the mcv.

       Todd

Share this post


Link to post
Share on other sites
65806    0

Step 1 would be change hydraulic filter.  See how bad that is. 

The brakes will work even without tractor running just not as good. 

Oil goes from MCV pump to steering than brakes than T/A than trans lube. 

Does the oil light by fuel gauge work?  If so does it go out when engine is running and light up when you push in the clutch?

Share this post


Link to post
Share on other sites
Cp 856    0

I have never seen the oil light come on so I am assuming it doesn't work. I took the lower plug out of mvc and it shot fluid while cranking it over a nice solid stream of oil. I am going to pull filter and look at it it looks like they put oil in it to move it at auction and it is at the full mark. No one knew how long it had set or why at the auction. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this