Jump to content


Photo

Cub 2072 Short Problems


4 replies to this topic

#1 852072

852072

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 30 March 2012 - 07:04 AM

I have a 1985 Cub Cadet 2072 Hydro. a few years ago i started haveing problems with it blowing fuses while it was running. I had heard from someone that it could possibly be the ignition switch. A year or so after hearing that i finally got a switch. But it didn't help the situation. thats when it wouldn't even crank before blowing the fuse. It would blow when ever i turned the switch fro the off position. Which turns out to be the Run with Lights. I just recently was told to check the Lighting Circuit. if anyone has any more suggestions it would be greatly appreciated.
1984 Cub Cadet 2072 Hydro
Getting a set of 21/2" chrome stacks soon

#2 Eason

Eason

    Advanced Member

  • Members
  • PipPipPip
  • 2,799 posts
  • Gender:Male
  • Location:Williamston -north eastern North Carolina
  • Interests:Anything IH

    IH & NC State; only the best are red & white.

Posted 03 April 2012 - 06:37 PM

I had the same problem on a 2166. I had a short in the lighting circuit. Eason
IH stuff I own 4900 dta466,6588,Hydro 86,784,674,966,664,826D hydro,856,656D hydro row-crop utility,2544D hydro utility,1026 gold demo, Farmall 504D, 340(junk) Farmall 100, 1980 Scout Terra diesel,1976 Scout II, 1975 race scout,67 Loadstar,1976 Sundance Loadstar cub cadets; Big Country4x2,2166,782, 682,1250,126, 125, 72,122, 100, original 76, spirit of 76 IH air conditioner, literature, toys and many parts scouts 1992 Ford F-250 7.3 4wd,1983 Ford F-250 4wd with IH 6.9 diesel Used to own a 656 row crop utility, 544D utility, and a 544D Farmall all 3 red and gold demo's and 7288 s/n 18

#3 852072

852072

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 09 April 2012 - 06:58 AM

thanks i'll go ahead and check that while its apart
1984 Cub Cadet 2072 Hydro
Getting a set of 21/2" chrome stacks soon

#4 852072

852072

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 08 May 2012 - 07:23 AM

It wasn't in the lighting circuit, it was in the Front PTO Clutch Circuit. The hot wire going from the starter switch, to the relay, to the PTO switch, then on down to the clutch was shorting out. So i just cut the wire cause there was still power going thru it whether the switch and the relay were pluged in. There were two wires going into the same terminal on the relay, onw wire came from the starter switch, and the other went to the PTO Switch, then there was another one on the PTO switch on the smae terminal that went on down to the PTO Clutch. Know i need to find out if its a chafed wire or if its a bad clutch.
Know I need to get it out of the garage and let it warm up. Run some Sea Foam through the Tank and Crankcase. Then do an oil change.
When i first fired it up it was burning oil and i was wondering if its anything serious it wasn't realy thick but it just concerns me cause i don't really want to pull the engine apart to replace rings.
And should i go ahead and change the Hyrdolic fluid and filter in the tranny. It has 745 hours on now.
1984 Cub Cadet 2072 Hydro
Getting a set of 21/2" chrome stacks soon

#5 Rainman882

Rainman882

    Advanced Member

  • Members
  • PipPipPip
  • 323 posts
  • Gender:Male
  • Location:WI,20" from Dr. E
  • Interests:Farmall Super C, W/FH, Cub Cadets, Plow Days

Posted 08 May 2012 - 08:53 AM

New Hytran & filter insure Hydro long life...if :)



Reply to this topic